>> 古い記事: Ubuntu Studio + Sound Blaster SX / .asoundrc
<< 新しい記事: (solved) Javascriptのエラー: Security error" code: "1000

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

Ruby/solved: gem でインストールに成功したが require すると "LoadError: no such file to load" と言われる

環境は Ubuntu Studio 8.04 / ruby 1.8.6 (2007-09-24 patchlevel 111) [i486-linux]

インストール先のパスを確認したり sudo でやってみたりしてもさっぱりうまくいかなくてまいりました。

要点は以下の2点。

  • 一般ユーザでインストール → ~/.gem/ruby/1.8/gems 以下にインストールされる。
  • foo をインストールした場合、foo を require する前に require "rubygems" しておく。

とりあえずは以上で使えるようになるのだけど、一般ユーザでインストールするとなぜか gem uninstall できないのが気になるところ。

>> 古い記事: Ubuntu Studio + Sound Blaster SX / .asoundrc
<< 新しい記事: (solved) Javascriptのエラー: Security error" code: "1000
** ホームに戻る

コメント

コメントの投稿

管理者にだけ表示を許可する

|
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。